[Cisco] Routage inter-Vlan

Après avoir vu la création de VLAN sur les switch Cisco, il est possible de mettre en place un routage inter-vlan pour permettre le transport de flux entre ces deux VLAN.
Ainsi, chaque PC d’un différent VLAN pourra communiquer avec son réseau dit « de base » ou le réseau d’un autre VLAN spécifié dans ce routage.

D’un point de vue branchements, vous devrez connecter un câble réseau de la prise (sélectionnée au préalable) du switch vers la prise réseau de votre routeur (qui sera elle aussi sélectionnée et configurée) ; Si le câble n’est pas branché, les VLAN ne pourra pas communiquer entre eux.


I. Commandes à effectuer sur le Switch

Le routage inter-VLAN se fera à l’aide d’un port « indépendant » sur notre switch. C’est grâce à ce port précis que le routage pourra se faire ; Il s’agit d’une sorte de passerelle entre les deux réseaux.

Switch>enable
Switch#configure terminal
Switch(config)#interface FastEthernet0/3
Switch(config-if)#switchport mode trunk
Switch(config)#exit

Le mode « trunk » peut être traduit par « pont » – c’est le mode de transport utilisé dans les switch pour faire un pont entre différents réseaux / flux. Dans notre exemple, la prise sélectionnée est la FE 0/3 mais vous pouvez naturellement prendre une autre prise indépendante, c’est-à-dire qui n’est pas dans un VLAN.

Il est préférable d’enregistrer la configuration, en cas de coupure électrique, ou de fausse manipulation par exemple. Vous devez donc lancer la commande « copy running-config startup-config » pour sauvegarder votre configuration (complète) du matériel.


II. Commandes sur le routeur

Première étape, il faut démarrer l’interface réseau physique du routeur qui vous servira de passerelle entre les réseaux.
Dans l’exemple, il s’agit de la prise n°0 :

Router>enable
Router#configure terminal
Router(config)#interface FastEthernet0/0
Router(config-if)#no shutdown
Router(config-if)#exit

Lorsque la carte réseau du routeur est allumée, il faut maintenant lui créer les deux interfaces virtuelles ; une interface virtuelle correspondra à « une passerelle virtuelle » pour chaque VLAN à « rejoindre ».

Commandes pour la première interface virtuelle du routeur :

Router(config)#interface fastEthernet 0/0.21
Router(config-subif)#no shutdown
Router(config-subif)#exit

Commandes pour la seconde interface virtuelle du routeur :

Router(config)#interface fastEthernet 0/0.22
Router(config-subif)#no shutdown
Router(config-subif)#exit

Rappel : La commande « no shutdown » permet d’allumer la carte et de prendre en compte les modifications qui lui ont été apportées.


Les interfaces physiques et virtuelles sont créées, il faut maintenant encapsuler les paquets pour qu’ils puissent transiter d’un VLAN à un autre.
Les commandes à passer sont similaires entre les interfaces, il faut être rigoureux quant à l’interface sélectionnée et à l’adresse IP de saisie.

Commandes pour la première interface virtuelle du routeur :

Router(config)#interface fastEthernet 0/0.21
Router(config-subif)#encapsulation dot1Q 21
Router(config-subif)#ip address 192.168.10.1 255.255.255.0
Router(config-subif)#no shutdown
Router(config-subif)#exit

Explications :

  1. Il faut entrer dans l’interface virtuelle précédemment créées pour mettre en place l’encapsulation des paquets ;
  2. La seconde commande permet d’activer cette méthode d’encapsulation ;
  3. Une adresse IP (et son masque) sont ajoutées à la carte réseau virtuelle – cette IP sera la passerelle pour le VLAN concerné (exemple : VLAN1 = interface virtuelle n°1 / VLAN2 = interface virtuelle n°2)
  4. Démarrage / sauvegarde de la configuration de cette interface par un « no shutdown« .

Commandes pour la seconde interface virtuelle du routeur :

Router(config)#interface fastEthernet 0/0.22
Router(config-subif)#encapsulation dot1Q 22
Router(config-subif)#ip address 192.168.20.1 255.255.255.0
Router(config-subif)#no shutdown
Router(config-subif)#exit
Router(config)#exit

A partir de cette étape, votre routage inter-vlan est prêt et opérationnel !
Le test est simple et rapide à effectuer : Essayez de pinger un PC du VLAN2 à partir de votre PC dans le VLAN1. Si le ping « répond », l’encapsulation est donc fonctionnelle et votre routage aussi !

Julien H

Passionné depuis toujours par l'informatique, je transforme ma passion en expertise. J'utilise quotidiennement les outils et systèmes Microsoft. Je ne délaisse pas mon côté ouvert, notamment via l'utilisation des OS Debian et Archlinux. L'infosec m'ouvre les yeux sur les enjeux actuels et futurs de l'IT.

Un commentaire

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

Fermer
Fermer