WordPress – plugin Broken Link Checker, erreur sur tous les liens HTTPS

L’extension « Broken Link Checker » dans WordPress vous remonte tous les liens cassés ou qui semble l’être. Toutefois, l’extension requiert un outil sur votre serveur web.

Petite mésaventure lors de la migration d’un site web disposant de « Broken Link Checker » > le plugin a remonté tous les liens HTTPS comme étant erroné. Plutôt embêtant lorsque le site est sous HTTPS partout… y compris pour les liens externes !

Le problème et sa résolution sont simples : il manque un paquet sur votre serveur web, plus précisément pour PHP. Il s’agit de « curl ». Installez le paquet selon votre version PHP de la sorte (ici pour PHP 7.2) :

apt install php7.2-curl

L’installation de « php-curl » permet à votre serveur web de faire des requêtes vers d’autres liens, sur plusieurs types de procoles.
Une fois les modifications faites, redémarrez le service PHP et le tour est joué !

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

Bouton retour en haut de la page
Fermer